1、如何配置把用户登陆信息和执行的操作记录到日志

# 设置用户登录/退出的LOG信息
Ruijie(config)#logging userinfo 

# 设置执行配置命令时,发送LOG信息
Ruijie(config)#logging userinfo command-log 

2、配置生成树MSTP

-----Core-1配置-----

# 开启生成树
Ruijie(config)#spanning-tree

# 进入生成树配置
Ruijie(config)#spanning-tree mst configuration

# 配置域名ID
Ruijie(config-mst)#revision 1

# 配置域名名称
Ruijie(config-mst)#name Ruijie

# 映射对应的vlan到对应的实例
Ruijie(config-mst)#instance 1 vlan 10 11 12
Ruijie(config-mst)#instance 2 vlan 20 21 22

# 退出生成树配置
Ruijie(config-mst)#exit

# 配置实例优先级
Ruijie(config)#spanning-tree mst 1 priority 0
Ruijie(config)#spanning-tree mst 2 priority 4096

-----Core-2配置-----

# 开启生成树
Ruijie(config)#spanning-tree

# 进入生成树配置
Ruijie(config)#spanning-tree mst configuration

# 配置域名ID
Ruijie(config-mst)#revision 1

# 配置域名名称
Ruijie(config-mst)#name Ruijie

# 映射对应的vlan到对应的实例
Ruijie(config-mst)#instance 1 vlan 10 11 12 
Ruijie(config-mst)#instance 2 vlan 20 21 22

# 退出生成树配置
Ruijie(config-mst)#exit

# 配置实例优先级
Ruijie(config)#spanning-tree mst 1 priority 4096
Ruijie(config)#spanning-tree mst 2 priority 0

# 查看生成树
Ruijie(config)#show spanning-tree sum

配置VRRP网关冗余协议,配置负载均衡、链路跟踪

-----Core-1配置-----

# 进入Vlan配置
Ruijie(config)#intface vlan 10

# 配置Vlan IP地址
Ruijie(config-if-VLAN 10)#ip address 192.168.10.252/24

# 配置VRRP网关 
Ruijie(config-if-VLAN 10)#vrrp 10 ip 192.168.10.254

# 配置VRRP优先级(主网关)
Ruijie(config-if-VLAN 10)#vrrp 10 priority 150

# 可选:配置跟踪上联IP地址(检测上联网关不正常,则切换主备网关)
Ruijie(config-if-VLAN 10)#vrrp 10 track 192.168.100.1 60(当检测到不能到达此地址,优先级降低60)

# 可选:配置跟踪上联接口(检测上联接口不正常,则切换主备网关)
Ruijie(config-if-VLAN 10)#vrrp 10 track g0/2 60(当检测到此接口不正常,优先级降低60)

# 输入 ?查看更多跟踪检测选项

-----

# 进入Vlan配置
Ruijie(config)#intface vlan 20

# 配置Vlan IP地址
Ruijie(config-if-VLAN 20)#ip address 192.168.20.252/24

# 配置VRRP网关
Ruijie(config-if-VLAN 20)#vrrp 20 ip 192.168.20.254

# 配置VRRP优先级(备网关)
Ruijie(config-if-VLAN 20)#vrrp 20 priority 100 (默认为100,可以不配置)

# 可选:配置跟踪上联IP地址(检测上联网关不正常,则切换主备网关)
Ruijie(config-if-VLAN 20)#vrrp 20 track 192.168.100.1 60(当检测到不能到达此地址,优先级降低60)

# 可选:配置跟踪上联接口(检测上联接口不正常,则切换主备网关)
Ruijie(config-if-VLAN 20)#vrrp 20 track g0/2 60(当检测到此接口不正常,优先级降低60)

# 输入 ?查看更多跟踪检测选项

-----

# 进入接口配置
Ruijie(config)#intface g0/2

# 开启三层口
Ruijie(config-if-GigabitEthernet 0/2)#no switchport

# 配置三层口IP地址
Ruijie(config-if-GigabitEthernet 0/2)#ip address 192.168.100.2/24

-----Core-2配置-----

# 进入Vlan配置
Ruijie(config)#intface vlan 10

# 配置Vlan IP地址
Ruijie(config-if-VLAN 10)#ip address 192.168.10.253/24

# 配置VRRP网关 
Ruijie(config-if-VLAN 10)#vrrp 10 ip 192.168.10.254

# 配置VRRP优先级(备网关)
Ruijie(config-if-VLAN 10)#vrrp 10 priority 100 (默认为100,可以不配置)

# 可选:配置跟踪上联IP地址(检测上联网关不正常,则切换主备网关)
Ruijie(config-if-VLAN 10)#vrrp 10 track 192.168.100.1 60(当检测到不能到达此地址,优先级降低60)

# 可选:配置跟踪上联接口(检测上联接口不正常,则切换主备网关)
Ruijie(config-if-VLAN 10)#vrrp 10 track g0/2 60(当检测到此接口不正常,优先级降低60)

# 输入 ?查看更多跟踪检测选项

-----

# 进入Vlan配置
Ruijie(config)#intface vlan 20

# 配置Vlan IP地址
Ruijie(config-if-VLAN 20)#ip address 192.168.20.253/24

# 配置VRRP网关
Ruijie(config-if-VLAN 20)#vrrp 20 ip 192.168.20.254

# 配置VRRP优先级(主网关)
Ruijie(config-if-VLAN 20)#vrrp 20 priority 150 

# 可选:配置跟踪上联IP地址(检测上联网关不正常,则切换主备网关)
Ruijie(config-if-VLAN 20)#vrrp 20 track 192.168.100.1 60(当检测到不能到达此地址,优先级降低60)

# 可选:配置跟踪上联接口(检测上联接口不正常,则切换主备网关)
Ruijie(config-if-VLAN 20)#vrrp 20 track g0/2 60(当检测到此接口不正常,优先级降低60)

# 输入 ?查看更多跟踪检测选项

-----

# 进入接口配置
Ruijie(config)#intface g0/2

# 开启三层口
Ruijie(config-if-GigabitEthernet 0/2)#no switchport

# 配置三层口IP地址
Ruijie(config-if-GigabitEthernet 0/2)#ip address 192.168.100.3/24

DHCP

  bootfile             Boot file name
# 引导文件               引导文件名称

  class                Specify a DHCP class
# 类型                  指定DHCP类型

  client-identifier    Client identifier
# 客户标识符             客户标识符

  client-name          Client name
# 客户名称               客户名称

  default              Set a command to its defaults
# 默认                  将命令设置为其默认值

  default-router       Default routers
# 默认路由               默认路由

  dns-server           DNS servers
# DNS Server            DNS服务器

  do                   To run exec commands in config mode
# -                    在配置模式下运行exec命令

  domain-name          Domain name
# 域名                  域名
  
  end                  Exit from DHCP pool configuration mode
# 退出                  从DHCP池配置模式退出

  exit                 Exit from DHCP pool configuration mode
# 退出                  退出DHCP池配置模式

  hardware-address     Client hardware address
# 硬件地址               客户端硬件地址

  help                 Description of the interactive help system
# 帮助                  交互式帮助系统的描述

  host                 Client IP address and mask
# 主机                  客户端IP地址和掩码

  lease                Address lease time
# 租赁                  地址租赁时间

  lease-threshold      Specify threshold percentage of pool lease
# 租赁阈值               指定池租赁的阈值百分比

  netbios-name-server  NetBIOS (WINS) name servers
# netbios名称服务器      NetBIOS(WINS)名称服务器

  netbios-node-type    NetBIOS node type
# netbios节点类型        NetBIOS节点类型

  network              Network number and mask
# 网络                  网络号和掩码

  next-server          Next server in boot process
# next-server          引导过程中的下一个服务器

  no                   Negate a command or set its defaults
# 否                   否定命令或设置其默认值

  option               Raw DHCP options
# 选项                  原始DHCP选项

  pool-status          Pool status
# 地址池状态             地址池状态

  show                 Show running system information
# 显示                  显示正在运行的系统信息

全局模式下配置命令

  <1-99>      Session number to resume
#             要恢复的会话号

  calendar    Set the calendar clock
#             设置日历时钟

  cd          Change directory
#             更改目录

  clear       Reset functions
#             重置功能

  clock       Manage the clock/calendar clock
#             管理时钟/日历时钟

  configure   Enter configuration mode
#             进入配置模式

  copy        Copy file from source to destine file or dir
#             将文件从源复制到目标文件或目录

  debug       Debugging functions (see also 'undebug')
#             启用调试功能(另请参见“ undebug”)

  delete      Delete file
#             删除文件

  dir         List directory contents
#             列出目录内容

  disable     Turn off privileged commands
#             关闭特权命令

  disconnect  Disconnect command
#             断开命令

  do          To run exec commands in config mode
# -           在配置模式下运行exec命令

  enable      Turn on privileged commands
#             启用特权命令

  erase       Erase disk
#             擦除磁盘

  execute     Execute scripts
#             执行脚本

  exit        Exit from the EXEC
#             从EXEC退出

  file        Display file attributes
#             显示文件属性

  help        Description of the interactive help system
#             交互式帮助系统的描述

  ip          Internet protocol
#             Internet协议

  led-blink   Blink for searching a device
#             闪烁,用于搜索设备

  lock        Lock the terminal
#             锁定终端

  mkdir       Make directories
#             制作目录

  more        Display contents of a file
#             显示文件内容

  no          Negate a command or set its defaults
#             否定命令或设置其默认值

  patch       Patch manage
#             程序补丁程序管理

  ping        Send echo messages
#             发送回显消息

  pwd         Print name of current working directory
#             打印当前工作目录的名称

  redundancy  Redundancy reload or switchover
#             冗余重新加载或切换

  reload      Reload switch
#             重启交换机

  rename      Move or rename files
#             移动或重命名文件

  renew       Renew
#             续约

  rldp        Rldp exec operation
#             Rldp exec操作

  rmdir       Remove a directory
#             删除目录

  session     To open a session with a module, use the session command in
              EXEC mode
#             要打开与模块的会话,在执行模式

  show        Show running system information
#             显示正在运行的系统信息

  switch      Convert switch mode
#             转换交换机模式

  telnet      Open a telnet connection
#             打开Telnet连接

  terminal    Set terminal line parameters
#             设置端子线参数

  traceroute  Trace route to destination
#             跟踪到目的地的路线

  tree        Tree display file
#             树显示文件

  undebug     Disable debugging functions (see also 'debug')
#             禁用调试功能(另请参见“ debug”)

  upgrade     Package manage
#             升级管理

  username    Username
#             用户名

  verify      Verify file MD5
#             验证文件MD5

  view        Global view info
#             全局查看信息

  write       Write running configuration to memory, network, or terminal
#             将运行配置写入内存,网络或终端

  zcm         Zero configuration mode switch
#             零配置模式开关

Configure状态下配置命令

  aaa                   Authentication, Authorization and Accounting
#                       认证,授权和计费

  access-list           Add an access list entry
#                       添加访问列表条目

  address-bind          Set a binding of IP and MAC address
#                       设置IP和MAC地址的绑定

  aggregateport         Aggregate port configuration
#                       聚合端口配置

  alias                 Create command alias
#                       创建命令别名

  arp                   Set ARP information
#                       设置ARP信息

  banner                Define a login banner
#                       定义登录标语

  boot                  Set boot system config
#                       设置引导系统配置

  bridge-frame          Bridge frame
#                       桥架

  class-map             Configure QoS Class Map
#                       配置QoS类映射

  clock                 Manage the clock timezone or summer-time
#                       管理时钟时区或夏令时

  cpu                   Config cpu item
#                       配置cpu项

  cpu-protect           Cpu protect
#                       CPU选项

  crypto                Crypto command
#                       Crypto命令

  cwmp                  Enter CWMP Configure Mode.
#                       进入CWMP配置模式

  default               Set a command to its defaults
#                       将命令设置为其默认值

  define                Interface range macro definition
#                       接口范围宏定义

  direct-vlan           Config direct vlan list
#                       配置直接VLAN列表

  dldp                  Exec data link detection command
#                       Exec数据链路检测命令

  do                    To run exec commands in config mode
#                       在配置模式下运行exec命令

  drr-queue             Configure Deficit Round Robin queues
#                       配置赤字循环队列

  enable                Modify enable parameters
#                       启用修改启用参数

  end                   Exit from configure mode
#                       退出配置模式

  erps                  Ethernet ring protection switching protocol
#                       以太网环保护交换协议

  errdisable            Error disable
#                       错误禁用

  exit                  Exit from configure mode
#                       退出配置模式

  expert                Expert extended ACL
#                       扩展ACL专家

  fiber                 Fiber
#                       光纤/光口模式

  ftp-client            Ftp-client config
#                       FTP客户端配置

  ftp-server            Ftp-server config
#                       FTP服务器配置

  gvrp                  GVRP configure command
#                       GVRP configure命令

  help                  Description of the interactive help system
#                       交互式帮助系统的描述

  hostname              Set system's network name
#                       设置系统的网络名称

  http                  Config http
#                       配置HTTP服务

  interface             Select an interface to configure
#                       选择要配置的接口

  ip                    Global IP configuration subcommands
#                       全局IP配置子命令

  key                   Key management
#                       密钥管理

  l2protocol-tunnel     Tunnel protocol
#                       隧道协议

  lacp                  LACP configuration
#                       LACP配置

  line                  Configure a terminal line
#                       配置终端线

  link                  Enable Link State Tracking feature
#                       启用链接状态跟踪功能

  lldp                  Link Layer Discovery Protocol
#                       lldp链路层发现协议

  logging               Modify message logging facilities
#                       修改消息记录功能

  login                 Enable password checking
#                       启用密码检查

  mac                   Mac extended ACL
#                       Mac扩展ACL

  mac-address-learning  Configure MAC address learning ability
#                       配置MAC地址学习能力

  mac-address-table     Configure the MAC address table
#                       配置MAC地址表

  mac-vlan              Mac vlan
#                       Mac VLAN

  maximum-paths         Configuration maximum paths
#                       配置最大路径

  memory                Configure memory related options
#                       配置内存相关选项

  memory-lack           Out of memory situation
#                       内存不足的情况

  mls                   Global Multi-Layer Switching parameters
#                       全局多层交换参数

  monitor               Configure SPAN monitoring
#                       配置SPAN监视

  msf                   MSF configuration
#                       MSF配置

  netconf               Netconf configuration commands
#                       Netconf 配置命令

  nfpp                  Enter Network Foundation Protection Policy Configure Mode.
#                       输入网络基础保护策略配置模式

  nlb-group             Nlb-group
#                       Nlb-group

  no                    Negate a command or set its defaults
#                       否定命令或设置其默认值

  ntp                   Configure NTP
#                       配置NTP

  offline-detect        Set offline-detect
#                       设置离线检测

  password              Set password parameters
#                       设置密码参数

  physical-port         Physical port dither protect
#                       物理端口抖动保护

  policy-map            Configure QoS Policy Map
#                       配置QoS策略图

  priority-queue        Configure priority scheduling
#                       配置优先级调度

  privilege             Command privilege parameters
#                       特权参数

  prompt                Set system's prompt
#                       设置系统的提示

  protected-ports       Protect route ports
#                       保护路由端口

  protocol-vlan         Global protocol-vlan configure
#                       全局协议-vlan配置

  qos                   Configure qos information
#                       配置qos信息

  radius                Config radius
#                       配置Radius

  radius-server         Configure radius server
#                       配置Radius服务器

  redundancy            Redundancy configuration
#                       冗余配置

  register              Register keyword
#                       注册关键字

  rldp                  Rldp global configuration
#                       Rldp全局配置

  rmon                  Remote Monitoring
#                       远程监控

  route-map             Create route-map or enter route-map command mode
#                       创建路线图或进入路线图命令模式

  router                Enable a routing process
#                       启用路由过程

  security              Config security 
#                       安全配置

  service               Modify use of network based services
#                       修改基于网络的服务的使用

  service-policy        Configure Global QoS Service Policy
#                       配置全局QoS服务策略

  sflow                 Configure sflow
#                       配置sflow

  show                  Show running system information
#                       显示正在运行的系统信息

  smp-server            Config smp-server
#                       配置smp-server

  snmp-server           Modify SNMP engine parameters
#                       修改SNMP引擎参数

  sntp                  SNTP protocol configuration
#                       SNTP协议配置

  spanning-tree         Spanning-tree subsystem
#                       生成树子系统

  station-move          Config station move
#                       配置工作站 移动

  svi                   Config svi router-acls
#                       配置svi路由器-acls

  switch                Enter VSU configuration mode
#                       进入VSU配置模式

  switch-mode           Switch-mode
#                       交换机模式

  switchport            Switchport port-security
#                       交换端口-安全性

  sysmac                Delete sysmac
#                       删除sysmac

  tacacs-server         Modify TACACS query parameters
#                       修改TACACS查询参数

  tftp-client           Tftp client config
#                       Tftp客户端配置

  tftp-server           Tftp-server config
#                       Tftp服务器配置

  time-range            Configure time range entries
#                       配置时间范围条目

  username              Establish User Name Authentication
#                       建立用户名身份验证

  virtual-group         Virtual group bundling configuration
#                       虚拟组捆绑配置

  vlan                  Configure VLAN
#                       Vlan配置

  voice                 Specify voice vlan
#                       指定语音VLAN

  vsl-port              Config vsl-port
#                       配置vsl-port

  web-auth              Web-auth command
#                       配置Web管理员命令

  webmaster             Config webmaster
#                       配置Web管理员

  wfq-queue             Configure Weighted Fair Queue queues
#                       配置加权公平队列队列

  wrr-queue             Configure Weighted Round Robin queues
#                       配置加权轮循队列

  zam                   Zam keyword
#                       Zam关键字